Vertex Indirect Tax Returns On-Demand Performance Incident

Incident Report for Vertex Inc

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 02:41 UTC

Investigating

Our monitoring processes indicate some customers are experiencing issues using email authentication when accessing the Returns on-demand application. However, authentication via mobile application is still functional. We are actively investigating and are troubleshooting the issue. We will provide an update as soon as possible. Thank you for your patience. If you have any questions, please submit a support ticket via the Vertex Community.
Posted Apr 11, 2025 - 02:11 UTC
This incident affected: Vertex Indirect Tax Returns North America On-Demand.