Vertex Indirect Tax O Series Cloud - Portal and Calc Performance Degradation

Incident Report for Vertex Inc

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 19:56 UTC

Identified

Vertex’s Production Support team has identified the issue and is working quickly on the resolution. We will continue to update our Status page with the latest information available.  If you have any questions, please submit a support ticket via the Vertex Community.
Posted Aug 21, 2025 - 19:28 UTC
This incident affected: Vertex Indirect Tax O Series Cloud (Calc, Portal).